Spout plugin install broken

Hi, I’m trying to get your UE Spout plugin working.

I cannot make the VS project files without adding an empty class. So I deleted the plugin to get the project to start properly again, and tried to make an empty class. Now Unreal will only accept Visual Studio as a compiler option. I use and am accustomed to VS Code, and even after changing UE editor settings to use VS Code for source code, it will only allow me to make an empty class if I install Visual Studio.

This will only be used in Blueprint based projects, and I was hoping for a process that I could show students to get work in and out of Unreal. A lot of Students will be working on machines without Visual Studio available, nor the option to install it. Where possible we try not to force software that will require paid licenses once they’re done studies.

What is the benefit of forcing compile on every install vs just providing the binaries directly in the git repo?
Is there a workaround to forcing everyone to install Visual Studio to compile this plugin?

I just downloaded all 6gb of Visual Studio, restarted, then tried to build Visual Studio project files.

I got an SDK error.

Now I’m trying to launch the project, and it’s returning “Could not be compiled. Try rebuilding from source manually” Almost 2 hrs into trying to get this plugin working, and all I have is a non-functional project.

Hi,

Which UE version are you using?

Thanks,

M

This is 4.25.1, the newest.

Hi,

Hmm, it is possible that some of the files didn’t get pushed to the repo, which is now fixed. So if you clone again, it should work.

For the record, you don’t need VS to build the plugin. In most cases, if it doesn’t build without VS, then installing it most likely won’t change anything (it would allow it to fix it, but that’s not your job :slight_smile: )

To make things easier please find here the plugin already built for 4.25.

Let me know how it goes.

Thanks,
M