Spout causes fatal error after build

Hey guys,

I embedded spout (sender) into my unreal engine project. If I run it in editor-mode everything runs smoothly and the Spout-Receiver receives the correct image. However, if I build my project (Package Project) and run the .exe nothing happens except a “fatal error” message appearing.

I already figured out that the connection between “Event Tick” and “Spout Sender” is causing the problem. If I disconnect them, everything works just fine (I just dont get my Spout-Out-Image :((( )

(I capture the Game Viewport. If you need more information to help me just ask for it!)

I hope someone can help! :slight_smile:

Greetings,
Sophie

Hi Sophie!

Thanks for posting on our Answerhub. What are you using spout plugin for, if I may ask? :slight_smile:

Did you see the Packaged game section in the Spout plugin’s readme file? Let me know if the info there helps.

Also, does the ‘fatal error’ message contain any other message?

Thanks,
Mitja

Hey!

Thanks for your answer.
I already looked at the readme file and followed the instruction. It did not work. There is no further information in the error message… (“Fatal error! The game has crashed and will close now”)

I want to send the picture from Unreal to Touchdesigner. In the editor-mode it works, but as soon as I Package the file I just get the error message.

Greetings,
Sophie

btw I already looked at this post:


The attatched drive-file works for me as well. would you mind sharing the UE-file?

I am working in UE 4.25.1, may this cause the problem?

Greetings,
Sophie

Hi,

Spout plugin has been confirmed to work in 4.25. Please make sure you have both the Spout Sender and Close Sender node properly set up and connected in your blueprint.

Thanks!
M