Mapping Unreal Engine Content on a 3D Printed Model

Just attach what i have from the Unreal nDisplayLauncher :

and what I expect to :


This is a quick explainer video, but I’ll try to send you a sample LightAct & a matching Unreal project for you to use as a baseline.

@Atsushi, you don’t need to create any Unreal cameras, nDisplay config file makes sure they are created automatically. And yes, the final output is straight from Unreal Engine. You can actually close LightAct application after nDisplay is running.

Have a quick look at the video and let me know if you have any questions. @NQ_3D, if you can, I’m happy to look at your LightAct project and, if possible, Unreal as well.


Hi Mitja thanks for the explanation,
unfortunately that doesn’t resolve my issue. :frowning:

Please find the files in the link below:

More over i have a question with scale. Because When you import in Unreal you have some information as scale model or not, and in WorldSetting you have some value to tansform unit world to meter so I have some trouble to understand the communication between LightAct 3D space and UE 3D space.

Thanks to you !

Hello Nicolas,

Thank you for sharing!

I think there is a problem with scale because the model in UE is much to small. Also, in LightAct the coordinates of the 3D model are not 0 and in UE there are.

Here’s what I did (I guess it’s a useful procedure so I’m describing it in full).

In LightAct, I moved the model to 0,0,0 and I inserted a box primitive and put it next to the model.

Projector output looks like this:

Then I inserted a cube primitive in Unreal and placed it at the same position adjusted for different coordinate system.

You can already see that the scale of the city model is wrong.

If I package the project and run it through nDisplay Launcher I get the correct perspective for the box

If you compare this image with the image of projector output from LightAct, you will see that the perspectives for the box match.

Then, I went back to UE Editor and set the scale of the 3D model to 10 and re-packaged it.

This is the output.

Now if we compare the output from nDisplay with the output from LightAct you see that there is a match.

Let me know if this helps.

That’s work, thanks a lot Mitja!
The cube provides me the information I need to make it scale correctly.

1 Like

I tried a simple model.
I was able to get the nDisplay from unrealLink to run well, too.
I found the tutorial video helpful.
I was able to get a general understanding of the flow of UnrealLink.

All I needed was an object in UE4 and I was good to go.
For object scaling, if I set UE4 to 1, I set it to 0.01 in Lightact.

I also tried UnrealLink with two projectors, 3Dcal and Autoblend.
I also roughly understood this setup process.
It’s still not a perfect fit, though.

It’s going to open up a lot of possibilities for me to try different things.

Thanks @NQ_3D,@meetya


Looks awesome, @Atsushi ! :partying_face: :+1: :muscle:

In general, the precision of projection mapping in UE should be the same as in LightAct, so your first task is to make projection mapping from LightAct as precise as possible. The key number to watch here is Reprojection error, which, ideally, should be kept below 1px or at least below 2px.

Good job, guys!

Hi again Mitja,
Love your set up @Atsushi, that’s Look pretty good !
On my side aimation is in progress but how to keep the camera static with nDisplay ? when i put my mouse in the projector the view is moving.

On the Unreal .cfg I can comment the mouse move axis but that line of code doesn’t appear in the UnrealLink .cfg file provided by LightAct :sweat_smile:

And i can’t see how to in UE4 because no camera is set in :slight_smile:


Hello Nicolas,

When creating our Unreal Engine Projection Mapping Starter Pack I was actually wondering about the same thing. I didn’t find an exact answer and I plan to ask on Unreal Developer Network.

In any case, this seems to be more of an Unreal Engine question, so I would suggest you ask on their support forums (and let me know afterwards :blush: )


1 Like

Sorry, didn’t read this thoroughly before: so you are saying that you found a way how to disable mouse input in the .cfg file? Can you share that? :slight_smile:

As an intermediate solution: if you know how, you can modify the .cfg file generated by LightAct any way you want.

on the nDisplay Template.cfg file, you have some line of code to activate the mouse detection but not in the cfg provided by lightact, that was my primary plan but I haven’t a solution for the moment.
I will share if I find a way!