Machine with Multiple NICs and How to Select a Specific NIC

Hi,

How do I change which NIC is set by default in LightAct? I have a machine with multiple NICs and would like to use 1x Dedicated for ArtNet, 1x Dedicated for NDI streams etc.

Can you only use one NIC at a time and not multiple simultaneously?

I wasn’t able to find much info in the documentation describing much to do with this scenario.

Cheers,

Hello Dale,

Thank you for your message.

You can select NIC for some devices but not for all. NDI is, due to how their SDK works, not among them at the moment.

However, you can select the default Art-Net NIC in the Preferences window:
image

And for a lot of other device nodes you can select the respective NIC in their properties on the right.
image

I hope this helps,
M

Thank you for the quick response,

I was hoping it may have been something like that, however as you can see from my screen shot below, I can only see the “Virtual Box” connection and not my “Scruffy 5G” wireless. And definitely no radio buttons either for selection.

When I disable the Virtual Box connection the wireless becomes the automatic default. So at least I know I can prove that and artnet is coming in from my ipad (photon) on Wifi when one of the connections is disabled.

I’m currently using the trial version should this matter?

As an FYI I’m looking to use LightAct mostly as a Bridge for Virutal Sets in UE4 and the Grandma Console, plus as an additional sequencer benefits and triggering from light act via spout to UE4 will also play a part. Previously I was quite heavily invested in D3/Disguise as my workflow, but no live events due to COVID19 has forced our hand to open our eyes at other options.

Cheers,

Dale Rehbein

Director

Onesandzeros Productions Pty Ltd

+61 405183670

Hey Dale,

Hmm, that’s weird. It’s not a limitation of Free licence, so at the moment I don’t know how come you don’t have a radio button :blush:. Also, I am assuming the listed IP (xxx.yyy.0.1) is the router’s IP, not yours, correct? It should list your IP.

It looks like it’s something in your network settings that’s causing this. I know it sounds like I am trying to shift the blame, so to speak, but that’s my best guess at the moment :innocent:

I would be interested to find out if you experience the same behaviour using a run-of-the-mill network setup such as a standard LAN connection and, say, a WiFi adapter.

Similarly to you, COVID has forced us to work from home, so atm I don’t have any means to run some tests on double NIC on a PC right now. I should be able to do that on Monday though.

I am very happy that you are considering LightAct for your workflow. FYI: there is some massive licencing upgrade coming your way in about 1 week that should be interesting to you. :wink:

Let me know what you find out with other network setups if you have the time.

Stay healthy :mask: :slightly_smiling_face:
Mitja

Hi Mitja,

I can explain the xxx.xxx.xxx.001 IP address. It is a virtual box connection which is essentially a DHCP server at xx.254 as it’s address.

The virtual machines are when i was running multiple e2 sims to previz for e2 shows.

When I disable that connection light act will revert to my wifi which has a 192.168.20.10 from the DHCP of my home wireless router. But strangely no radio button still.

Looking forward to hearing about this new licensing as well.

I will no doubt be in touch with other more complex scenarios as I get deeper into the workflow.

Cheers,

Dale

Hello,

I had the chance to look into this today. So first things first:

You don’t see a radio button, because the socket is running. That means that you are sending out Art-Net data from one of Art-Net nodes in the Devices window. If you uncheck their Streaming checkboxes the radio button should appear.

Alternatively, if you start a blank LightAct project (just open one of the sample projects) and open the eDMX tab in the Preferences window, you should see a radio button even if there is just one.

So please start one of the simple Sample projects from the Welcome window, go to the eDMX tab and let me know if you still see just one network interface.

Hopefully, you’ll see something similar to this:
image

Best regards,
Mitja